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1. Purpose 
 
The Purpose of CFD Lab 2 is to conduct parametric studies for turbulent flow around Clark-Y airfoil 
following the “CFD process” by an interactive step-by-step approach. Students will have “hands-on” 
experiences using ANSYS to investigate the effect of angle of attack and effect of different turbulence 
models on the simulations results. These effects will be studied by comparing simulation results with EFD 
data. Students will analyze the differences and possible numerical errors, and present results in Lab report. 
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2. Simulation Design 
 
In EFD Lab 3, you have conducted experimental study for turbulent airfoil flow around a Clark-Y airfoil 
(Re≈300,000). The data you have measured were used for CFD PreLab 2. In CFD Lab 2, simulation will be 
conducted under the same conditions of EFD Lab 3, except angle of attack and turbulent models that will be 
changed in this lab.  
 
The problem to be solved is turbulent flow around the Clark-Y airfoil with angle of attack (α) 
 
 

Table 1 - Geometry dimensions 
Parameters Symbol Unit Value 

Chord Length C m 0.3048 
Domain radius Rc m 12 
Angle of attack α m 16 

 
 
 

 
Figure 1 – Geometry 
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3. Opening ANSYS Workbench 
 
3.1. Start > All Programs > ANSYS 17.1 > Workbench 17.1 

 
 

3.2. From the ANSYS Workbench home screen (Project Schematic), drag and drop a Geometry, Mesh, and 
two Fluent component from the Component Systems drop down menu onto the Project Schematic. 
Project Schematic should resemble the schematic below. Rename the components as per below. 

 
 

3.3. Create a Folder on the H: Drive called CFD Lab 2. 
3.4. Save the project file by clicking File > Save As… 
3.5. Save the project onto the H: Drive in the folder you just created and name it CFD Lab 2 Turbulent Flow. 
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4. Geometry 
 

4.1. Right click Geometry then select Import Geometry > Browse… Select airfoil.igs and click OK. 
Note: The airfoil geometry is found on the class website http://user.engineering.uiowa.edu/~fluids/ 
under the heading CFD PreLab2. 

 
 
 

4.2. Right click Geometry and select Edit Geometry in DesignModeler… 

 
 
 
 
 
 
 
 
 
 

 

 

http://user.engineering.uiowa.edu/%7Efluids/
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4.3. Click Generate. 
 
 

4.4. Select Sketching > Constraints > Auto Constraints. Enable the auto constraints option to pick the 
exact point as below. 
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4.5. Create > Body Transformation > Rotate. Select the airfoil and click Apply. Click the yellow box 
labeled Axis Selection then click the XYPlane in the Tree Outline, then click Apply. Change the 
Angle to 16° and click Generate. 

 

 

 

1 2 

3 4 
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4.6. Select XYPlane and click New Sketch button. 

 
 
 

4.7. Select the sketch you created and click sketching button.  
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4.8. Sketching Toolbox > Draw > Circle. Click on the xy-plane origin and click behind the airfoil. (Click z-
arrow at right bottom to set the view as perpendicular to xy-plane) 

 
 
 
4.9. Sketching Toolboxes > Dimensions > General. Click on the circle and change the diameter to 12m. 
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4.10. Concept > Surface From Sketches. Select Sketch1 from the Tree Outline, click Apply, then click 
the Generate button. 

 
 

4.11. Create > Boolean. Change operation to Subtract then select the circle for Target Bodies and click 
Apply then select airfoil (click on the airfoil until only the airfoil’s color turns yellow) for Tool Bodies 
and click Apply then click Generate. This will subtract the airfoil surface from the circle.  
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4.12. Concept > Split Edges. Select the perimeter of the circle and click Apply. Select Generate.  This 
should split the circle into two semicircles. You can see the semicircles by selecting the perimeter above 
and below the x-axis. 

 
 
 

4.13. Repeat the process from 4.12 on the two semicircles. This should yield four circular quadrants. 
 
 
4.14. Repeat this process for the arc in quadrant IV (lower right). Change the Fraction to 0.822222. This 

splits the arc into a 16° and a 74° arc.  
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4.15. Concept > Lines From Points. Draw a line from the point on the circle to the point on the airfoil 
making sure to hold Ctrl while doing so. (Note: The point on the front part of the airfoil is not exactly on 
the origin, you need to make sure to select the point on the airfoil and not the origin. Zoom in and find the 
point just below the origin and select that point. The images below show the locations of the points circled. 
When selecting points to generate lines with, be sure to select the point on circle and then the point on the 
airfoil as to avoid complications when sizing mesh). 

 

 

  

airfoil 

fluid domain 

Line should be connected to this point  

origin 
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4.16. Once you select both points click Apply, then click Generate. 
 

 
4.17. Repeat this process creating lines from the edge of the circle to the airfoil starting from the circle and 

ending at the airfoil (A to A’, B to B’ and C to C’). The images below show the locations of the points on 
the airfoil and the points on the circle. 

 
 
 

4.18. Tools > Projections. Select the four lines you created for Edges and select the circle for Target then 
click Generate. This will split your geometry into four sections 

    . 
 
 

 

 

 

 
 

 C 

A 

B 

A’ 

B’ C’ 

 



 13 

4.19. Tools > Merge. Change the Merge Type to Edges. Select the 16° arc and the arc in quadrant I and 
select Apply. Click Generate. This merges the lines into one line which can be sized for meshing easier. 

 
4.20. File > Save project and exit. 

 
 
 
 
 
 

5. Mesh Generation 
 

5.1. From the Project Schematic right click on Mesh and select Edit… from the dropdown menu. 
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5.2. Right click Mesh then Insert > Face Meshing. Select the four surfaces while then click Apply. 
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5.3. Right click Mesh and Insert > Sizing. Select two edges as per below and change the parameters as per 
below. You might need to change the cursor to “Edge selector” at this moment. 
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5.4. Right click Mesh and Insert > Sizing. Select two edges as per below and change the parameters as per 
below. 

 
 
 

5.5. Right click Mesh and Insert > Sizing. Select all for lines leading from the circle to the airfoil surface, and 
click Apply. Change parameters as per below. Note: If you did not create the lines starting from the outer 
circle and ending on the airfoil surface, you may have issues with biasing. If this is your case, size the 
lines individually making sure that the sizing is finest at the surface of the airfoil. 
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5.6. Right click Mesh and Insert > Sizing. Select the surface at the top of leading edge of the airfoil and 
click Apply. Change Parameters as per below. 

 
 
 
5.7. Right click Mesh and Insert > Sizing. Select the surface at the bottom of leading edge of the airfoil and 

click Apply. Change Parameters as per below. 

 
 
 

5.8. Right click Mesh and Insert > Sizing. Select the surface at the top of trailing edge of the airfoil and 
click Apply. Change Parameters as per below. 
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5.9. Right click Mesh and Insert > Sizing. Select the surface at the bottom of trailing edge of the airfoil and 
click Apply. Change Parameters as per below. 

 
 
 

5.10. Click on Mesh under the Outline, under the Details of “Mesh”, change the Physics Preference from 
Mechanical to CFD. This changes the grid solver to a fluids style solver rather than a FEA style solver. 

 
 
 

5.11. Click Generate Mesh. Click on the Mesh button under the Outline and make sure it resembles the 
mesh below.  
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5.12. Hold Ctrl and select the two left most semicircle arcs, right click on them and select Create Named 
Selection, name the selection inlet. Use the edge select button from the toolbar. 

 
 
 

5.13. Do the same for the two right most semicircle arcs and name them outlet. 
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5.14. Select the four arcs that make the airfoil, right click and Create Named Selection and name it airfoil. 

 
 
 

5.15. Now use the face button to select the four semicircle quadrants and Create Named Selection and 
name them fluid. 

 
 

5.16. File > Save Project. Exit the window. 
5.17. Right click Mesh and select Update from the dropdown menu. 
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6. Setup  
 

6.1. From the Project Schematic right click on Setup and select Edit… 

 
 
 

6.2. Select Double Precision and click OK. 
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6.3. Solution Setup > Models > Viscous –Laminar > Edit… Change the parameters as per below and click 
OK. (For the k-ω case, you will select k-omega (2 eqn)). 

 
 

k-ε model 

 
 
 

k-ω model 
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6.4. Solution Setup > Materials > air > Create/Edit… Change parameters as per experimental data and 
click Change/Create. 

 
Use the air properties at the room temperature when you conducted EFD Lab3. You can use the following 
website to calculate air properties from the temperature: 
http://www.mhtl.uwaterloo.ca/old/onlinetools/airprop/airprop.html 
The values in the figure above are for 24° temperature. 
NOTE: viscosity used in ANSYS is the dynamic viscosity ( kg m s⋅ ), NOT kinematic viscosity ( 2m s ) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  

 

 

 

http://www.mhtl.uwaterloo.ca/old/onlinetools/airprop/airprop.html
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6.5. Solution Setup > Boundary Conditions > inlet > Edit… Change parameters as per experimental data 
(blue box) and default values (red boxes) and click OK. The experimental value can be found from the 
EFD Lab 3 data reduction sheet. 

 
k-ε model 

 
 
 

k-ω model 
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6.6. Solution Setup > Boundary Conditions > Outlet > Edit… Change the parameters as per below and 
click OK. (Use outlet B.C. for both k-ε and k-ω models) 

 
 

6.7. Solution Setup > Reference Values. Change parameters as per below. The Velocity, Temperature, 
Density, and Viscosity should be entered from EFD data.  
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6.8. Solution > Solution Methods. Change parameters as per below for both k-ε and k-ω models. 

  
 

6.9. Solution > Solution Controls. Change Parameters as per below. (If you have problems with the 
solution converging, you can decrease the Under –Relaxation Factors.) 

 

 

 

 
Make sure you 
scrolled down 
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6.10. Solution  >  Monitors > Residuals –Print, Plot > Edit….  Change the convergence limit to 1e-05 
for all five equations. 

 
 
 

6.11. Solution > Solution Initialization. Change the parameters as per below and click Initialize. 
 

k-ε model                                                          k-ω model 
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6.12. Solution > Run Calculation. Change the Number of Iterations to 10000 and click Calculate. 

 
 

Iteration history should look similar to the one below. 
 

 
 
 
 

6.13. File > Save Project. 
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7. Results 
 

7.1. Plotting and Saving Residual History 
 

Solution > Monitors > Residuals –Print, Plot > Edit… > Plot > Ok. 
 

 
 
File > Save Picture… > Save… Make sure the parameters are as per below and click Save… Name the file 
“CFD Lab 2 Residual History” change the file directory to the CFD Lab 2 file you created on the H: drive and 
click OK. 
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7.2. Plotting Pressure Coefficient Distribution with CFD and EFD Data 
 
Results > Plots > XY Plot > Set Up… > Load File… Select “Pressure-coef-attack16.xy”. Change the 
parameters as per below and click Plot. Save the picture the same way as you did for Residual History but in 
this case, name it “CFD Lab 2 Pressure Coefficient Distribution”. 
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7.3. Plotting Contour of Pressure 
 
Results > Graphics > Contours > Set Up… Change the parameters as per below and click Display. Save the 
picture the same way as you did for Residual History but in this case, name it “CFD Lab2 Contour of 
Pressure”. 
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7.4. Plotting Contour of Velocity Magnitude 
 
Results > Graphics and Animations > Contours > Set Up… Change the parameters as per below and click 
Display. Save the picture the same way as you did for Residual History but in this case, name it “CFD Lab 2 
Contour of Velocity Magnitude”. Zoom in where you can see the airfoil clearly and the change in contour 
levels around the airfoil. 
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7.5. Plotting Velocity Vectors at Trailing Edge 
 
Results > Graphics and Animations > Vectors > Set Up… Change parameters as per below and click 
Display. Save the picture the same way as you did for Residual History but in this case, name it “CFD Lab 2 
Vectors of Velocity at Trailing Edge”. Zoom in on the trailing edge. 
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7.6. Plotting Streamlines Close to Airfoil Surface 
 
Results > Graphics and Animations > Contours > Set Up… Change parameters as per below and click 
Display. Save the picture the same way as you did for Residual History but in this case, name it “CFD Lab 2 
Streamlines Close to Surface”. Adjust Min and Max values until streamlines cover the airfoil. 
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7.7. Printing Lift and Drag Coefficients 
 
Results > Reports > Forces > Set Up… Change parameters as per below and click Print. This prints out the 
drag force. If you change the X parameter to zero and the Y parameter to 1, this prints out the lift force. Save 
the coefficients by clicking Write. This creates a text file of what was printed on the screen. Name the file 
“Drag Coefficient” or “Lift Coefficient”. 
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8. Exercises 
 

Parametric Studies of Turbulent Flow around an Airfoil 
 

• You must complete all the following assignments and present results in your CFD Lab 2 reports  
         following the CFD Lab Report Instructions. 

• Use “CFD Lab2 Report Template.doc” to save the figures and data for each exercise below. 
• Use the benchmark EFD data from the class website if your EFD Lab 3 data are with a different 

angle of attack than 16 degrees. 
 
 

1. Effect of angle of attack. 
Use the same flow conditions as those in your EFD Lab 3, including geometry (chord length) and 
setup (Flow properties, Reynolds number, inlet velocity), EXCEPT use angle of attack 16 
 Degrees regardless of AOA in you EFD Lab 3. Use k-ε model, 2nd order upwind scheme, double 
precision with iteration number (2000) and convergent limit (10-5).  
• Figures need to be saved: 1. Time history of residuals (residual vs. iteration number); 2.  

       Pressure coefficient distribution (CFD and EFD), 3. Contour of pressure, 4.Velocity vectors, and 5.  
       Streamlines 

• Data need to be saved: lift and drag coefficients 
 
2. Effect of turbulence models 

2.1. Use the same conditions as those in exercise 1, EXCEPT using the “k-ω” for “viscous models”. 
Set up the boundary conditions following instructions part, set the iteration number to be (2000), and 
convergent limit to be 10-5. Perform the simulation and compare solutions with the simulation results 
using “k-ε” model (you have finished in CFD PreLab2) 
• Figures need to be saved: 1. Time history of residuals (residual vs. iteration number); 2. 

Pressure coefficient distribution (CFD and EFD), 3. Contour of pressure 4. Velocity vectors, and 
5. Streamlines 

• Data need to be saved: lift and drag coefficients 
 
3.  Questions need to be answered in CFD Lab2 report: 
     Using the figures obtained in exercises 1 and 2 in this Lab and those figures you created in CFD  
     PreLab2 to answer the following questions and present your answers in your CFD Lab 2 report. 
        Note: These questions are also available in the “CFD Lab2 Report Template” where you will type 
answers. 

3.1. For Exercise 1 (effect of angle of attack): 
   (1). Which angle of attack simulation requires more iterations to converge? 
   (2). Which angle of attack produces higher lift/drag coefficients? Why? 
   (3). What is the effect of angle of attack on lift and drag coefficients?  
   (4). Describe the differences of streamline distributions near the trailing edge of airfoil surface for  
          these two different angles of attack. Do you observe separations for both? If so, does the     

separation occur at the same location? 
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3.2. For Exercise 2 (different turbulence models): 
(1). Do the two different turbulence models have the same convergence path? If not, which one  
       requires more iterations to converge. 
(2). Do the two different turbulence models predict the same results? If not, which model predicts  
       more accurately by comparing with EFD data? 

            3.3. For the following contour plot, qualitatively compare the values of pressure and velocity  
                   magnitude at point 1 and 2, if the flow is from left to right. Which location has higher pressure  
                   and which location has higher velocity magnitude? Why? 

 

 
             3.4. Questions in CFD PreLab2. 
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