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1. Purpose

The Purpose of CFD Lab 3 is to simulate turbulent flows inside a diffuser following the “CFD
process” by an interactive step-by-step approach and conduct verifications. Students will have
“hands-on” experiences using ANSYS to conduct validation of velocity, turbulent kinetic
energy, and skin friction factor. Effect of turbulent models will be investigated, with/without
separations. Students will manually generate meshes, solve the problem and use post-processing
tools (contours, velocity vectors, and streamlines) to visualize the flow field. Students will analyze
the differences between CFD and EFD and present results in a CFD Lab report.
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2. Simulation Design

The problem to be solved is that of turbulent flows inside an asymmetric diffuser (2D). Reynolds
number is 17,000 based on inlet velocity and inlet dimension (D1). The following figure shows
what the geometry looks like with definitions for all geometry parameters. Before the diffuser, a
straight channel was used for generating fully developed channel flow at the diffuser inlet. You
will conduct simulation for two different half angles of 4 and 10 with two different turbulence

models of SST and k-¢.

Table 1 — Main particulars

Parameter Symbol Unit Value
Inlet dimension D1 m 2
Inlet length L1 m 60
Diffuser half angle o degree 40r10
Outlet dimension D2 m 94
Outlet length L2 m 70
' )
b
¥ D2
| ™) Half angle
I il
L1 '
I—-‘. - I—-‘. =I

In CFD Lab3, all EFD data for turbulent airfoil flow in this Lab can be found on the class website

http://www.engineering.uiowa.edu/~me 160/.



http://www.engineering.uiowa.edu/~me_160/

3. Starting with ANSYS Workbench

3.1. Create the layout as per below.
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i ": Geometry i 1
2 @ Geometry P 4 22 @ Mesh T d a2 a Setup T 4
Geometry Mesh 3 Soluton T
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3.2 File > Save. Save the project on the network drive and Call it “CFD Lab 3”.



4. Geometry Creation

In this section, we will create the geometry for the diffuser with 10 degree half angle, then copy
and modify the geometry for the 4 degree half angled diffuser.

4.1 Right click Geometry and select New DesignModeler Geometry...
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4.2 Make sure that Unit is set to Meter and Degree (default value).
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4.3 Select XYplane and click New Sketch button.
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4.4 Right click Sketchl and select Look at.
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4.5 Sketching > Constraints > Auto Constraints. Enable the auto constraints option to pick the
exact point as below.
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4.6 Sketching > Draw > Line. Draw a vertical line on the y-axis starting from the origin as shown
below (P indicates that the origin point is selected and V indicates that the line is vertical).
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4.7 Sketching > Dimensions > General. Click on the vertical line then click on the left side of the
line to place the dimension. Change the dimension in Details View to 2m (skip the unit ([m])

when put in the value).
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4.8 Sketching > Draw > Line. Create a horizontal line on the x-axis starting at the origin as per
below (H indicates that line is horizontal).

4.9 Sketching > Dimensions > General. Change the length of the horizontal line you created to
60m.

4.10 Sketching > Draw > Line. Create line at an angle with respect to x-axis as shown below.

4.11 Sketching > Dimensions > Angle. Select the line just created then select the x-axis then
change the angle to 10°. (Note: if ANSY'S gives a default exterior angle instead of the interior
angle, right click and select Alternate Angle.)
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4.12 Sketching > Draw > Line. Create a horizontal line as per below.

4.13 Sketching > Dimensions > General. Change the length of the line just created to 70m.

4.14 Sketching > Draw > Line. Draw the horizontal line circled in red line as per below.

4.15 Sketching > Constraints > Equal Length. Select two lines circled in red as shown below.
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4.16 Sketching > Draw > Line. Draw the horizontal line circled in red as per below.

4.17 Sketching > Constraints > Equal Distance. Click on Point 1 and then click on the Point 2.
Click Point 3 and then click on line 4. This makes points 1 and 3 the same distance from the
y-axis in the horizontal direction.

4.18 Sketching > Draw > Line. Draw the horizontal line circled in red as shown below.

4.19 Sketching > Constraints > Equal Length. Click on two lines circled in red as below.
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4.20 Sketching > Draw > Line. Draw the final line circled in red as shown below. When you
draw this line, if all previous dimensions and constraints are correct, the line should have two
P’s at the ends with a V in the center. This indicates that the line starts and ends on the two
points and is perfectly vertical. If you do not get the V, recheck all dimensions and constraints.
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4.21 Sketching > Dimensions > General. Change the length of the line circled in red to 9.4m,
this will automatically adjust the length of the expansion region because of the applied
constraints.
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4.22 Concept > Surfaces From Sketches. Select the sketch you created and click Apply then
click Generate. This will create a surface as shown below.
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4.23 Tools > Face Split. Select the surface you created (it will be highlighted in green when
you select it as shown below) then click Apply for Target Face.
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ils View
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4.24 Click on the yellow region shown below.
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4.25 While holding Ctrl button click on the two points circled in red then click Apply button.

View 1
=1 Details of FaceSplit1
Face Split | FaceSplit1

-I| Face Split Group 1 (RMB)
Face Split Type | By Points and Edges
Target Face 1

Apply I Cancel

4.26 Click on the region marked with red rectangle below.
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1

4.27 While holding Ctrl button click on the two points circled in red then click Apply button.




4.28 Click the Generate button and Save your progress.
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4.29 Close the ANSYS Design Modeler and update geometry
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4.31 Rename the new geometry file as per below.

- A - B - C
2 m Geometry " 4 -2 ﬁ Mesh & -2 a Setup T 4
10 degree half angle Mesh 3 @3 solution T
k-

8 ' Geometry
2 m Geometry " 4
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4.32 Open the new geometry file you created and select Sketchl under the tree outline as per
below. Change the half angle to 4 degrees under details view as per below then click the
Generate button.
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4.33 Save your file and quit ANSYS Design Modeler



5. Mesh Generation

This section shows how to generate the mesh for both 4 degree and 10 degree half angle cases.

5.1 Right click on Mesh and click Edit...
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5.2 Right click on Mesh then select Insert > Face Meshing.
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5.3 Select all three surface while holding Ctrl button and click Apply located Geometry.
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5.4 Select the Edge button. This will allow you to select edges of your geometry.
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5.5 Right click on Mesh and Insert > Sizing.
ealewe

 Mame ¥ | Search Outline | ™ _
T Project*
=] Model (B2)
H- /T8 Geometry
- I Surface Body
m Materials
- ¢34 Coordinate Systems
o

i Insert P <h Method
B update X9 sizing
$  Generate Mesh 'l Contact Sizing
Preview » Refinement | Sizing
<h » Face Meshin E Control size-related|
= 9 size, number of divi
4 Create Pinch Controls Mesh Copy M sphere or body of ir
= Group All Similar Children Match Control
Finch (D Press F1 for help.
O Clear Generated Data
Inflation
b Rename F2

Mesh Connection Group
Start Recording
Manual Mesh Connection

Contact Match Group
Contact Match

Mode Merge Group
Mode Merge

¢ R RRBDIEL O B

Mode Move




20

5.6 While holding Ctrl, click on the edges shown below and click Apply.

Details of "Edge Sizing” - Sizing

=l| Scope
Scoping Method |Ge::umetr3r Selection
Geometry Apply I Cancel
[=| Definition
Suppressed Ma
Type Element Size
[ "] Element Size Default (2.3017 m}
[=1| Advanced
Behavior Soft

| | Growth Rate | Default (1.2)
Capture Curvature | Mo

Capture Proximity |Mo

Bias Type Mo Bias

5.7 Change parameter for Edge Sizing as per below (Left edge is shown as an example).

Details of "Edge Sizing" - Sizing
2] Scope
Scoping Method Geometry Selection
Geometry 2 Edges
[=|| Definition
Suppressed Mo
Type Mumber of Divisions
|| Number of Divisions | 59
[=I| Advanced
Behavior Hard
Capture Curvature Mo
Capture Proximity Mo
Bias Type . ___ _____ ___ _
Eias Option Bias Factor
| | Bias Factor 15,106




5.8 Right click on Mesh and Insert > Sizing.

5.9 While holding Ctrl, click on the edge shown below and click Apply.
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5.10 Change parameter for Edge Sizing as per below and click Apply (Right edge is shown as

an example).

=] Scope
Scoping Method

Details of "Edge Sizing 2" - Sizing

Geometry Selection

Geometry 2 Edges
[=|| Definition
Suppressed Mo
Type Number of Divisions
|| Mumber of Divisions |59
[=|| Advanced
Behavior Hard
Capture Curvature Mo
Capture Proximity Mo
Eias Type W ___ ____ ___ _
Eias Option Eias Factor
|| Bias Factor 87.76
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5.11 Right click on Mesh and Insert > Sizing.

5.12 While holding Ctrl, click on the edge shown below and click Apply.

Details of "Edge Sizing 3" - Sizing

Scoping Method Geometry Selection
Geometry 2 Edges
[=]| Definition
Suppressed Mo
Type MNumber of Divisions
|| Mumber of Divisions |59
= Advanced
Behavior Hard
Capture Curvature Na
Capture Proximity Na
Eias Type o
Bias Option Eias Factor
| | Bias Factor 3.6776
Reverse Bias Mo Selection
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5.14 Right click on Mesh and Insert > Sizing.

5.15 While holding Ctrl click on the edge shown below and click Apply.

5.16 Change parameter for Edge Sizing as per below and click Apply.

Details of "Edge Sizing 4" - Sizing
2] Scope
Scoping Method Geametry Selection
Geametry 2 Edges
[=]| Definition
Suppressed Mo
Type Mumber of Divisions
[ | Mumber of Divisions | 59
[=I| Advanced
Behavior Hard
Capture Curvature Mo
Capture Proximity Mo
Bias ype . ___ _____ ___ _
Bias Option Bias Factor
|| Bias Factor 1.8593
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5.17 Right click on Mesh and Insert > Sizing.

5.18 While holding Ctrl click on the edge shown below and click Apply.

5.19 Change parameter for Edge Sizing as per below and click Apply.
Details of "Edge Sizing 3" - Sizing

2] Scope
Scoping Method Geometry Selection
Geometry 2 Edges
[=|| Definition
Suppressed Mo
Tvpe Mumber of Divisions
|| Mumber of Divisions | 59
[=I| Advanced
Behaviar Hard
Capture Curvature Mo
Capture Proximity Mo
Bias Type o
Bias Option Bias Factor
|| Bias Factor 43763
Reverse Bias Mo Selection
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5.20 Mesh > Physics Preference. Change from Mechanical to CFD (Once you click the Mesh

under the Outline, detailed options will appear as below).
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5.22 Select Geometry to hide the mesh and click the Edge button.
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5.23 While holding the Ctrl button select the three top edges and right click on them, then select
Create Named Selection. Change the name to top_wall and click OK. Similarly name the
bottom_wall (bottom), inlet (left) and outlet(right).
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@ Zoom To Selection (7)

@3 Image To Clipboard (Ctri+ )

Cursor Mode »

View »
#9 Look At
rea MN)...
X
(Ctrl+

)
) Select Mesh by ID (M)...

B B oo fomSoue




Selection Name *

IT_.OE wall| *

®) Apply selected geometry
) Apply geometry items of same:

[ size

Type

Location X

Location Z

[
]
D Location Y
[
]

Apply To Corresponding Mesh MNodes

I ak. I Cancel

5.24 File > Save Project and quit ANSYS Mesh. Right click on Mesh and click Update

hd A A B - C
2 Geometry 2 . Mesh——= o =
4 Edit...
10 degree half angle Mesh)
53  Duplicate
Transfer Data From Mew 3
Transfer Data To New 4
[/ update

Update Upstream Components
Clear Generated Data
'_f‘ Refresh

Reset

4 degree half angle

5.25 Repeat this process for 4 degree and 10 degree half angle cases.

5.26 You should have the project schematic below.

- B = c
1 Mesh I8 | Fluent
®2 @ Mesh v CZﬁSetup &,
10 degree half angle Mesh 3 Soluton ¥
k-e
v D = :
1 : S
2 2] Geometry " 22 @ Mesh v

4 degree half angle Mesh



6. Setup

6.1 Right click Setup and click Edit.

- A A B % C
2 E Geometry v Me—— ) Mesh 1  e—— 2 Q
10 degree half angle Mesh 3 £ B cde.
Register Startup Scheme File...
Import Fluent Case And Data
Import Fluent Case
- 3 - = 23 Duplicate
1 1 Transfer Data From New
Geometry '  Se— 2 @ vesh ) Transfer Data To New
4 degree half angle Mesh #  Update
Update Upstream Components
Clear Generated Data

6.2 Check Doub

le Precision and select START.

. Fluent Launcher 2022 R1 (Setting Edit Only)

Fluent Launcher

- d s

Simulate a wide range of steady and transient industrial applications using the
general-purpose setup, solve, and post-processing capabilities of ANSYS Fluent
including advanced physics models for multiphase, combustion, electrochemistry,

and more.

Dimension

Options
Double Precision

Display Mesh After Reading
(_) Do not show this panel again

() Load ACT

Parallel (Local Machine)

Solver Processes

Solver GPGPUs per Machine g

~ Show More Options “ Show Learning Resources

1

LR ARE B

Start || Cancel || Help

-
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6.3 Tree > Setup > General > Mesh > Check. Set the parameters as per below.

Outline View Task Page E‘
Filter Text General @‘
=) Setup Mesh
General
+ @ Models [ Scale... |l Check I[Rapart Qual\tyl
+) &8 Materials ﬁ ﬁ
+ [1] cell Zone Conditions w' &'
+ [ Boundary Conditions
2l Dynamic Mesh Solver
[Z] Reference Values Type Velocity Formulation
L f— ST Fram.as @ Pressure-Based ®' Absolute
= s.ﬂut'm:amm Bxpressions Density-Based Relative
% Methods
- Gniirm - Time 2D Space
=/ Report Definitions ® Planar
+ @ Monitors ®) Steady )
Axisymmetric
@ cell Registers Transient X X
=% Initialization SEATmITET S
+ # Calculation Activities
© Run Caleulation
- Results )
& surfaces Sty
+) @ Graphics
+ | Plots
+) [F] Animations
+) [ Reports
+ Parameters & Customization

6.4 Tree > Setup > Models > Viscous. Select parameters as per below and click OK(Apply).

B viscous Model *
Model Viodel Constants

Inviscid e

Laminar 0.09

Spalart-Allmaras (1 eqn) C1-Epsilon
| @ k-epsilon (2 eqn) | 1.44

k-omega (2 eqn) C2-Epsilon

Transition k-kl-omega (3 eqn) 1.92

Transition SST (4 eqn) TKE Prandtl Number

Reynolds Stress (5 eqn) 1

Scale-Adaptive Simulation (SAS)
Detached Eddy Simulation (DES)

TDR Prandtl Number

1.3
k-epsilon Model
RNG
Realizable
Near-Wall Treatment User-Defined Functions
Standard Wall Functions Turbulent Viscosity
Scalable Wall Functions none v
Non-Equilibrium Wall Functions Prandtl Numbers
I @ Enhanced Wall Treatment | TKE Prandtl Number
Menter-Lechner none -
User-Defined Wall Functions TDR Prandtl Number
none v

Enhanced Wall Treatment Options

I | Pressure Gradient Effects I

Options
Curvature Correction
Production Kato-Launder
Production Limiter

(cance  etp




6.5 Tree > Setup > Materials > Fluid > air. Change the fluid properties and then click

Change/Create then click Close.

Name Material Type Order Materials by
air fluid M ® Name
Chemical Formula Fluent Fluid Materials Chemical Formula
air v
[ Fluent Database...
Mixture 3
none - | [6RANTA MDS Database...
[User—l)eﬁned Dal:aba;e...|
Properties
Density [kg/m] constant * | Edit...
B |
Viscosity [kg/(m s)] constant ¥ || Edit...
I 0.000147 I

[Change!Create || [ Delete | Hilp|
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6.6 Tree > Setup > Boundary Conditions > Zone > inlet. Change parameters for inlet velocity.

Use the table below for as per below and click OK(Apply).
B velocity Inlet X

Zone Mame
inlet

Mamentum Thermal Radiation Species DPM Multiphase Potential Structure ups

Velocity Specification Method jComponents i
Reference Framef Absolute -

Supersonic/Initial Gauge Pressure [Pa] p -
*-Velocity [m,fs]l 1.25 I'
Y-Velocity [m/s] o hd
Turbulence
Specification Method K and Epsilon -
Turbulent Kinetic Energ',rl[l'ﬂzﬁHTI
Turbulent Dissipation Rate [m*/="1]0.0000963 | R

D (o) ()

Inlet Boundary Condition
Variable u(m/s) | v(m/s) | P(Pa) | k(m"2/s"2) e(m”2/s"3)
Magnitude 1.25 0 - 0.0018 9.63e-05
Zero Gradient - - Y - -
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6.7 Tree > Setup > Boundary Conditions > Zone > outlet. Change parameters as per below and
click OK(Apply).

Zone Name
outlet
Momentum Thermal Radiation Spedes DPM Multiphase Potential Structure uns
Backflow Reference FrameIAbsolute h I
Gauge Pressure [Pa]lu I -
Pressure Profile Multiplieril I -
Backflow Direction Specification MethodINormaI to Boundary +J I
Backflow Pressure SpeciﬁcationITotaI Pressure - I
Prevent Reverse Flow
Average Pressure Specification
Target Mass Flow Rate
Turbulence
Specification Methodl Intensity and Length Scale W I
Backflow Turbulent Intensity [%Iz‘_zs—l hd

Backflow Turbulent Length Scale [m]lu_uu35

o [EES

Iv

Outlet Boundary Condition
Variable u(m/s) | v(m/s) | P(Pa) | Intensity (%) | Length scale (m)
Magnitude - - 0 3.25 0.0035
Zero Gradient Y Y - - -

6.8 Make sure boundary condition type is wall for top and bottom walls.

Task Page ®  Task Page ]
Boundary Conditions [@ Boundary Conditions

Zone [Filter Text %) (F]  zone Fiter Te

bottom_wall bottom wall. .

inlet inlet

interior-surface_body interior-surface_body

outlet outlet

surface body surface_body

‘tap wall top_wall

Fhase ype o) Phase
midure ¥ || wall * |6 TLIEE

[ Edit...

| Copy.. ][Prnﬁlesm ‘

[

Display Mesh.,.l

[Operating Conditions...

Periodic Conditions...

Type D
[ Edit... } | Copy... ”Pmﬁles... ‘

l Parameters... ‘

Display Mesh...|

|operating conditions...|

Periodic Conditions...

Wall Boundary Condition
Variable u(m/s) | v(m/s) | P(Pa) | k(m"2/s"2) e (m"2/s"3)
Magnitude 0 0 - 0 0
Zero Gradient - - Y - -




6.9 Tree > Setup > Reference Values. Change reference values as per below.

Outline View

Filter Text

- Setup
General
+ @ Models
=) &F Materials
=) £ Fluid
&¢ air
+ LF solid
+) [ cell Zone Conditions
-/ B Boundary Conditions
=) 2 Inlet
o inlet (velocity-inlet, id=8)
+ [ Internal
+) 2% Outlet
- = wall
—. bottom_wall (wall, id=7)
—. top_wall (wall, id=8)
£¥ Mesh Interfaces

1 Dynamic Mesh
| | Reference Values
+ |, Reference Frames

£+ Named Expressions

<

-

Task Page

Reference Values

Compute from

Reference Values

Area [m?] 0.
Density [kg/m?] 1
Depth [m] 1
Enthalpy [J/kg] O
Length [m] 1
Pressure [Fa] 0
Temperature [K] 288.16
Velocity [m/s] 1.25

Viscosity [kg/(m s)] [0.000147

Ratio of Specific Heats 1.4
Yplus for Heat Tran. Coef. 300

Reference Zone

In case of ‘Yplus for Heat Tran. Coef’ leave it as a default value (300)

6.10 Tree > Solution > Methods. Change the solution methods as per below.

Outline View

Filter Text

= Setup

& General

@ Models

£ materials

[ cell Zone Conditions
[ eoundary Conditions
£¥ Mesh Interfaces

& Dynamic Mesh

[Z] Reference Values

[7, Reference Frames
fo Named Expressions

iqi-' Methods I

Contraols
=/ Report Definitions
+) @ Monitors
& Cell Registers
T Automatic Mesh Adaption
/2, Initialization
+ # Calculation Activities

) ) ()

+

<

Task Page

Solution Methods

Pressure-Velocity Coupling

Scheme

Second Order Upwind

SIMPLE A
Flux Type

Rhie-Chow: distance based + Auto Select
Spatial Discretization

Gradient

Green-Gauss Cell Based >
Pressure

Second Order >
Momentum

Second Order Upwind -
Turbulent Kinetic Energy

Second Order Upwind -
Turbulent Dissipation Rate
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6.11 Tree > Solution > Monitors > Residual. Change convergence criterions to 1e-05 and
click OK(Apply).

Options Equations
+| Print to Console Residual Monitor Check Convergence Absolute Criteria
V| Plot continuity v v 1e-05
Curves... | Axes... | x-velocity L L 1e-05
Tterations to Flat y-velocity v v 1e-05
i - k v v 1e-05
epsilon v v 1e-05
Iterations to Store
1000 -
Convergence Conditions...
| Show Advanced Options
Residual Values Convergence Criterion
Normalize Iterations absolute =
V| Scale = -
Compute Local Scale
_Renormaﬁze]
[ﬁ| _Cancel] [Flp‘

6.12 Tree > Solution > Initialization. Change parameters as per below and click Initialize.

Solution Initialization @l

Initialization Methods

Hybrid Initialization
I ® Standard Initializationl

Compute from

Reference Frame

® Relative to Cell Zone
Absolute

Initial Values
Gauge Pressure (pascal)
]
X Velocity (m/s)
|o.ss7 |
Y Velocity (m/s)
0

Turbulent Kinetic Energy (m2/s2)

|0.0018 |
Turbulent Dissipation Rate (m2/s3)
|o.63e-05 |

Reset| Patch...

Reset DPM Sources  Reset Statistics




6.13 Tree > Solution > Run Calculation. Change Number of Iterations to 10,000 and click
Calculate.

Run Calculation ®|
[ Check Case... Update Dynamic Mesh...
Parameters
Number of Iterations Reporting Interval
| 10000 <] 1 -
Profile Update Interval

1 =

Solution Processing
Statistics
Data Sampling for Steady Statistics

[ Data File Quantities...
Solution Advancement
| Calculate
Residuals
—continuity I\nsys
—x-velocity 1e+01 2022 R1
——y-velocity 1
=ik 1e+00
epsilon \

1e-01

1e-02

1e-03

b \ |

1e‘05 —_ \\
1 \‘\\\\\

16-06 - ——

1e-07 ' | ' | ' | ' | ' | ' | ' | ' | ' |
0 50 100 150 200 250 300 350 400 450

Iterations

6.14 Save your project and quit ANSYS fluent.
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6.15 Duplicate the k-e setup for 10 degree half angle case to 4 degree angle case as per below
then run the case. You need to make new connection between 4 degree case’s mesh and
duplicated setup. Once you enter the new setup, initialize first and then run.

v| A v B v C
2 [ ceometry v - €2 @ Mesh v - 4 7 Update
10 degree half angle Mesh 3 Duplicate I
Mg Export System(s)
Clear Generated Data
X Delete
v D v B EE Rename
=] =gl
2 |[B ceometry v - -2 ‘e Mesh ' , Add Note
4 degree half angle Mesh
After simulation runs
v A v B v o
2 |IE] Geometry v/ - @2 |@ Mesh v 4T a2 1& Setup Vv
10 degree half angle Mesh 3 @@ soluton v
k-e
v D v B v| C
= \
2 =] Geometry v a0 a2 0 Mesh AT o2 ;e Semp v 4
4 degree half angle Mesh 3 ‘@ Solution v/
k-e




6.16 Duplicate the k-e setup for 10 degree half angle and rename it as SST

v A
1 s Geometry
2 | B ceometry v M

10 degree half angle

v D
1
2 | B ceometry v -

4 degree half angle

v B
#2 @ Mesh v A< .2 e Setup Vv 4
Mesh ‘\"-. 3 @ Solution v/ ‘.

k-e

v B
B e
#2 (@ Mesh v -
Mesh

6.17 Right click and select Edit....

- A

1 s Geometry

v B

:

2@ Mesh v

2 & ceomery v .
10 degree half angle

- D

il # Geometry

2 m Geometry " 4=

4 degree half angle
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hl

D

T

42 @ Sewp Vv
/|3 €3 solton &
: SsT

Mesh
5
hd B E{a
B - e |

a2 @ Mesh v - a2 |@ setp v

Mesh 3! @ Solution v F
k-e

alb

Register Startup Scheme File...

Import Fluent Case And Data

Import Fluent Case

Duplicate

Transfer Data From New
Transfer Data To New

Update

Update Upstream Components

Clear Generated Data

Refresh
Reset
Rename
Properties

Quick Help
Add Note
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6.18 Tree > Setup > Models > Viscous. Select SST model and use the default parameters as per
below then click ok(Apply).

Model Model Constants
Inviscid Alpha®_inf -
Laminar 1
Spalart-Allmaras (1 eqn) Alpha_inf
k-epsilon (2 eqn) 0.52
k-omega (2 eqgn) Beta™ _inf
Transition k-kl-omega (3 eqn) 0.09

I ®) Transition S5T (4 eqn) I -

Reynolds Stress (5 eqgn) 0.31

Scale-Adaptive Simulation (SAS)

Detached Eddy Simulation (DES) Beta_i (Inner)
0.075

Transition 55T Options Beta_i (Outer)
Roughness Correlation 0.0828

Options

Curvature Correction . .
. User-Defined Transition Correlations
Corner Flow Correction

Production Kato-Launder F_length

Production Limiter nane =
Re_thetac
none -
Re_thetat
none -

m . Cancel | @|

6.19 Tree > Solution > Controls. Change Under-Relaxation Factors as per below.
Solution Controls @|

Under-Relaxation Factors
Density 1

1

Body Forces
1

Momentum
0.5

Turbulent Kinetic Energy
0.5

Specific Dissipation Rate
0.5

Intermittency
0.5

Momentumn Thickness Re
0.5

Turbulent Viscosity
1

_Default]
[Equations...] [Limits....l Advanced...l
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6.20 Tree > Solution > Initialization > Initialize.

6.21 Tree > Solution > Run Calculation > Calculate.
After finish the calculation, File > Save Project. Then Close the window

6.22 Duplicate SST fluent setup for the 4 degree half angle case and run the simulation as per

below (You should initialize before running the case).

v A v B v C v D
g Geomery | g vesh ! > [Fent

2 Geometry v/ '
10 degree half angle

v E

.

2 Geometry v/
4 degree half angle

o2 Mesh v =

Mesh

v B

g ven |

a2 Mesh v/ =

Mesh

@2 @ sep Vv
3 ﬁ Solution v/
k-e

v C

:

a2 a Setup Vv 4
3 % Soluton "
k-e

2 @ setp v

3 ﬁ Soluton v 4
SST

v D

42 a Setup Vv

3 | @ souton v/
ssT
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7. Results (Read exercises (Section 8) before continuing.)

7.1 Creating lines for modified TKE and modified U plots.

Setting Up Domain > Surface > Create > Line/Rake. Create 7 lines at the given location on
the table.

User-Defined Solution Results Parallel Design
Mesh Zones Interfaces Mesh Models Adapt Surface
@ Display... @ d*) E‘ Scale... w Combine . EEi‘ Delete... r_ﬁ Append - E Mesh... a Dynamic Mesh... \_J Refine [ Coarsen...
O mfe . = ‘::_7 L Transform | UJj separate .. Fg Deactivate... EE@ Replace Mesh... @I Overset... | 3 Mixing Planes... Zone...
f# units... ~ Check-  Quality - Make Polyhedra | o Adjacency... [ Actvate.. O Replace Zone... @ Turbo Tapalogy... | oo More Partition...
Imprint...
Outfine View Task Page = B i
Point...
AL Run Caiculation 6] ne/Rake..
= Setup Plane.
Efceneal Check Case...l Update Dynamic Mesh... Qs Line/Rake
uadric...
+) @ Models
* £ Mmaterials Options Iso-Surface...
+) [ cell Zone Conditions
+» @O Boundary Conditions Data Sampling for Steady Statistics 150-Clip...
P 5 ling Interval
7z Dynamic Mesh ampling In en‘a TETE T
[£] Reference Values 1 2 Sampling Options...

Mew Surface Mame

||:|05iti0n—1 |
Options Number of Points
Line Type 10 =
Resetl Line -
End Points
x0 (m)|78 | xt (m)|78 |
yo (m)|-3.52 |yt (]2 |
z0 (m) |0 z1 (m) |0

[Select Points with Mnuse|

(chose | (neip|

<
—_

Surface Name | x0 y0 x1
Position-1 78 -3.52 78
Position-2 82 -4.23 82
Position-3 86 | -4.9371 86
Position-4 98 -7.053 98
Position-5 102 -7.4 102
Position-6 110 -7.4 110
Position-7 118.5 -7.4 118.5

[NSHRESRE SRESRE RN SN S]
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7.2 Defining custom field functions for modified U, modified TKE and skin friction coefficient.

User-Defined > Custom. Write the equation shown below and click Define. You will need
to look up the Field function and the buttons to enter the parameters in the Definition.
Definitions of the variables and custom field function that need to be defined are shown on

table below.
Field Functions User Defined Model Specific
I £/ custom... | 5 Memaory... =1 1D Coupling...
o . cinctinn Hooks...
El# units... 2 Scalars... ) Fan Model...
Custom...
] Paramet: 28] Create custom field functions n Demand... @ Read Table...
Definition
[lo=vx+x-60 |
[ ” X ” / ”y X HABS | Select Operand Field Functions from
| Field Functions
mv ” sin ” co: [tan [ In Hbgll}] Mesh -
{ ! |{ 2 |{ > |{ ¢ |{SQRT:| X-Coordinate v
s [ 6 | |8 ) 9| CEICJ (seieet]
¢ o Jler e ]l . Jor] —
Mew Function Name|u=10+x | |
[Manage... | [Cbse | [Help |
Function Name Definition
u*10+x (Modified U) 10*Vx+x-60
k*500+x (Modified TKE) 500*turb-kinetic-energy+x-60
skinfriction-coefficient x-wall-shear * 2 / density / 1.25 2
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7.3 Plotting modified U and modified TKE

Instruction for plotting modified U is given here. The only difference between modified U
and modified TKE plot is a different “X-axis function”.

Results > Plots > XY Plot > Set Up... > Load File... Select the ‘Modified_u-10degree.xy’
file downloaded from the class website and click OK

Note : Make sure about options as shown below.
Turn off “Position on X Axis” and Turn on “Position on Y AXis”

XY Plot Mame
wy-plot-1
Options Plot Direction ¥ Axis Function
| Node Values %0 Direction Vector o
Position on X Axis Y1 X Axis Function
V| Position on Y Axis Z|0 | custom Field Functions... -
Write to File
. | uF10+x - I
Order Points

i ) . Surfaces |Filter Text e | F:'| E/| = |

File Data [1/1] EIEE ) — DL
— Load File... Inlet

|Profiles of modified velocity | + Internal

[ Free Data | = L'”e;‘;r_;;c:q
position-2
position-3
position-4
position-3
paosition-6
position-7

+ Qutlet

+) Wall

New Surface ,|

|| Save,"Pth [Axes... | [Curues... I [ Close | @|

You can compare EFD and CFD using the customizing functions (Curves...) on the lines
you created as per below. Be careful about the axis location as shown below

Ansys
2.00e+00 — et s
1.00e+00
3 .
0.00e+00 | b
] .
-1.00e+00 — )
-2.00e+00
Position -3.00e+00
position-1 [m] ]
position-2 -4.00e+00 —
position-3 =
position-4 -5.00e+00 —
position-5 ]
—— position-6 -6.00e+00 —
position-7 2
*  Experimental, x=18 ~7.006+00
*  Experimental, x=22 .8.00e+00 ]
*  Experimental, x=26 . § K
*  Experimental, x=38 15 20 25 30 35 40 45 50 55 60 65
*  Experimental, x=42 u*10+x
* Experimental, x=50
¢ Experimental, x=58.5

7.4 Plotting skin friction coefficient
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Results > Plots > XY Plot > Load File... Select the ‘Skin_Friction bot wall.xy’ file
downloaded from the class website and click OK.

Change the parameters as per below and click Plot.

X Plot Name
xy-plot-2
Options Plot Direction Y Axis Function
| Node Values X1 I Custom Field Functions... e I
Ll =iz eE3LEt s I skinfriction-coefficient v I
Position on Y Axis Zio V—
Write to File
: Direction Vector v
Order Points
Surfaces |Filter Text %| F | %| '=><|
File Data [1/1] SEE “ol = 2
————— |Load File... *) Inlet
ISkJ'n friction. Lower wall (H:/9. TAfSkIn_frictI‘ ) +/ Internal
Free Data | : gn;-stur‘face
= utle
= wall
lbottom wall ]
top_wall
| > |Hew Surface |
Save/Plot [Axes...l [Curves... | [Close| Help|

You can change the axis by clicking Axes... under XY plot. Change the x-axis min and max
to 60 and 130 respectively (uncheck Auto Range) and click Apply. Change the y-axis max
and min to 4e-03 and -1e-03 respectively. Click Apply and click Plot again.

bottom_wall
AnNnsys

——e—— Experimental -1.00e-03 — 2021 R2

-5.00e-04 —

0.00e+00 — //' \

5.00e-04

1.00e-03 _
skinfriction-coefficient 1.50e-03 J
2.00e-03 —
2.50e-03 —
3.00e-03 —|

3.50e-03 —

60 70 80 90 100 110 120 130
Position [m]



7.5 Total friction
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Results > Reports > Forces. Select the zone where you want to calculate the total force
then select print. This will print a report as per below

R Direction Vector Wall Zones |Filter Text E| [_;| E| E|
®! Forces X|1 i —
Moments vl bottom_wall
top_wall
Center of Pressure 70

[Save Qutput Parameter...

m [Write...] [Close | [Help |

Forces - Direction Vector (1 0 0)

Forces
Forces (n)
Zone Pressure Viscous Total
bottom wall (1.0585937 35.9174%94 0) {0.34016388 -0.0010073304 0) {1.399150% 35.916487 0)
Net (1.0585937 35.9174%94 0) {0.34016388 -0.0010073304 0) {1.399150% 35.916487 0)

Het
1

Forces (n) Coefficients
Zone Pressure Viscous Total Fressure Viscous Total
bottom wall 1.0585837 0.340163388 1.399150% 5.4220134 1.7416391 7.1636525
1.058937 0.34016388 1.399150% 5.4220134 1.7416391 7.1636525




7.6 Finding the pressure difference between inlet and outlet.
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You can simply write pressure at bottom wall to a file and take the difference of pressure at

inlet and outlet.

Write to File
|| order Points

File Data [0/0]

DS

XY Plot Name

xy-plot-3

Options Plot Direction Y Axis Function
Node Values X Pressure... -
Fosition on X Axis Y Static =
[ Position on Y Axis zlo |

X Axis Function

| Direction Vector

x|

Surfaces |Filter Text | @

+) Inlet

@ Internal

@ Line-surface
(+) Qutlet

@

bottom_wall

top_wall

[Twete.| (v ) [curves..] [cioe]

-0.6000

-0.7000

-0.8000

Position (m)

0.0000 25.0000 50.0000 75.0000 100.0000 125.0000 150.0000 175.0000 200.0000 225.0000 250.0000




7.7 Plotting contours, velocity vectors and streamlines.
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Refer to previous manuals for lab 1 and 2 for plotting streams, velocity vectors and pressure
distributions. You can change the scales and levels for vectors and streamlines respectively to

show the separation region. Few examples are shown at below.

Contour ame
contour-1
Options Contours of
7 Fled Pressure... 2
' Node Values [ static Pressure M|
Contour Unes | yrToncoal) Max (pascal)
: i::" Range (56409174 0.0002356742
o Rarge o &
Draw Profies
Draw Mesh

dhethaise

N
i
SIZZI=ZT

b ininin it B R OO
444

E#z:t# &
441344414

0 ) o )

& x|

[Vector Name

vector-1

Options Vectors of
V! Global Range Velocity

[Style

3d arrow =
[Scale Skip

0.03 0 2

Vector Options...

V' Auto Range Color
[7] Clip to Range Velocity...
V' Auto Scale
- Velocity Magnitude
|| Draw Mesh

Min (m/s)
7.07381e-05
Surfaces [Filter Text
(*) Fluid

*) Inlet

+) Internal

) Line-surf:

Custom Vectors...

) Outlet
+ wall

New Surface

Max (m/s)
(1444933

RJ(B)E
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zones Interfaces Mesh Models Turbomachinery Adapt Surface
] scole... &3 Combine g Delete.. [ Append | e Z] oynamic Mesh... & Tubo Worklow | Tip Manual.. T Automatic.. | + Create .
i Transform . | ) Separote . g Deoctivate... 5 Reploce Mesh... 3 Mixing Planes... 15 Turbo Create... € Turba Topology. 2% Controls... /i Monage... /4, Manage...
QBIY ~ & ake poiphedra | o+ Adjocency..  gxf Actwate... Ol Reploce zone... | B0 OVErSE | o o wodel.. & Feriodi Intancng...
¢ TaskPage = = Contours of Stream function [kg/s] x B Scaled Residuals x
Filter Text
: Slv contourt Ansys
H ] pr— . Stream Funciion 2022 R1
2, Species o | E 2618400
*) J Discrete Phase (Of, Cantaurs of “
& Solidification & Mi| Filad Velocity. 2.35e+00
A Acoustics (0f) || ¥ node v
2 Sructre O || 5 cormurrmes LSt Euncton ' 2.09e+00
58 porentiala-ion sal Vi (kg1 Wax Chols]
&) & Materials 2 j:f:":”“' 0 o - 1.838+00
*) 3 cell Zane Conditions e = i
) 3 Soundary Candions || - /P ° arce =) 1.57@+00
ry ]-
€3 Mesh Interfaces oraw Profies | b ottom wall k
2] Dynarmic Mesh Oraw Mesh inlet =

[ Reference values
) 12, Referance Frames
f Mamed Expressions

interior-surface_body
outlet

surface_body
Display State
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8. Data Analysis and Discussion
8.1 Simulation of turbulent diffuser flows without separation (4 degree) (+20)

8.1.1 Run simulations for 4 degree half angle diffuser with k- model.

8.1.2 Run simulations for 4 degree half angle diffuser with SST model.

8.1.3 Questions:

e Do you observe separations in 8.1.1 or 8.1.2? (use streamlines)

e What are the differences between 8.1.1 and 8.1.2 regarding modified u, modified TKE, and
the variables in the following table?

Turbulent model Total pressure difference Total friction force on the
between inlet and outlet (Pa) upper wall (N)
SST
k-e

Relative error (%)

e Figures need to be reported (for both 8.1.1 and 8.1.2):
(1) Residual history (2) Modified u vs. x (3) Modified TKE vs. x (4) Contour of pressure
(5) Contour of axial velocity (6) Velocity vectors and streamlines

e Data need to be reported: the above table with values.

8.2 Simulation of turbulent diffuser flows with separation (10 degree) (+22):

8.2.1 Run simulations for 10 degree half angle diffuser with k-& model.

8.2.2 Run simulations for 10 degree half angle diffuser with SST model.

8.2.3 Questions:

e Do you observe separations in 8.2.1 or 8.2.27 (using streamlines)

e Comparing with EFD data, what are the differences between 8.2.1 and 8.2.2 on the following
aspects: (1) Modified velocity (2) Modified TKE (3) Skin friction factor on top and bottom
walls (4) Variables in the following table.

Turbulent models Total pressure difference Total friction force on the
between inlet and outlet (Pa) upper wall (N)
SST
k-e

Relative error (%)
e If any separation shown, where is the separation point on the diffuser bottom wall (x=?) and

where does the flow reattach to the diffuser bottom wall again (x=?) (use wall friction factor)
e Do you find any separation on the top wall?

e Figures need to be reported (for both 8.2.1 and 8.2.2):
(1) Residual history (2) Modified u vs. x with EFD data (3) Modified TKE vs. x with EFD
data (4) Skin friction factor distributions on top and bottom walls with EFD data (5) Contour
of pressure (6) Contour of axial velocity (7) Velocity vectors and streamlines with appropriate
scales showing the separation region if the simulation shows separated flows.

e Data need to be reported: The above table with values.
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8.3 Questions need to be answered in CFD Lab3 report

8.3.1 Questions in exercises 8.1-8.2.
8.3.2 By analyzing the results from exercise 1 and exercise 2, what can be concluded about the

capability of k- € and SST models to simulate turbulent flows inside a diffuser with and
without separations? (+3)



9. Grading scheme for CFD Lab Report

(Applied to all CFD Lab reports)

Section

1 Title Page
1.1 Course Name
1.2 Title of report
1.3 Submitted to “Instructor’s name”
1.4 Your name (with email address)
1.5 Your affiliation (group, section, department)
1.6 Date and time lab conducted

2 Test and Simulation Design
Purpose of CFD simulation

3 CFD Process

Describe in your own words how you implemented CFD process
(Hint: CFD process block diagram)
4 Data Analysis and Discussion & Section 8 (Page# 47) for CED Lab 3
Answer questions given in Exercises of the CFD lab handouts
5 Conclusions
Conclusions regarding achieving purpose of simulation
Describe what you learned from CFD
Describe the “hands-on” part
Describe future work and any improvements

Additional Instructions:

1. Each student is required to hand in individual lab report.
2. Conventions for graphical presentation (CFD):
* Color print of figures recommended but not required
3. Reports will not be graded unless section 1 is included and complete

Total

Points

5

10

20

45

20

100
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